Outgun / 1.0 / Test versions

Outgun 1.0 test versions

Two years of development, albeit with long periods of no progress, have taken place after the last stable release in version 1.0.3. The results are available here as unstable test versions, while the code still needs a lot of work until we’re satisfied enough to release it as 1.0.4.

The test versions are compatible with regular Outgun 1.0, but many new features require both the client and server to be upgraded. The versions are identified as 1.0.3 with an internal revision number added. Not all internal revisions are released, and not all the released ones end up here. While we try to put here at least the most significant improvements, you can find all recently released versions directly on Nix’s computer when it’s on, which is almost always.

Don’t expect everything to work flawlessly, but please do give feedback when it doesn’t. The documentation is missing or outdated in many areas, and translations are missing for many newly added phrases. These things will get better in time, but for the translations we obviously need help of either the original translator or someone else.

Contents

Latest news

2008-03-18 Test versions available

Our current development code is now available as a test version. Calling it version 1.0.4 is still far away, so we decided to let everyone look at the work in progress.

There are some great new features and lots of smaller ones added, as well as bugs corrected from 1.0.3. Some of the most important features, all of which can be turned off at will, are:

Unfortunately, being still under development, many of the features are not exactly how we like them yet, and especially not always user friendly. There are also probably lots of new bugs.

From now on, new test versions will be released quite often whenever development is in progress. Remember to check back here, as there is no automatic notification within Outgun for new test versions (yet), like there is for final releases.

More news

See the news archive for older news and those not related to 1.0 test versions.

Download

The test versions have almost the same package structure as 1.0.3. The upgrade packages only contain files changed since Outgun 1.0.3, so if you only have Outgun 1.0.2 or older, you need to download the full package or first upgrade to 1.0.3.

Linux users wanting to compile from the sources need to notice that official releases of HawkNL fail at runtime when compiled in 64-bit mode. This also affects other versions of Outgun. A patched version of HawkNL will be released by us in the near future. In the meantime, you need to use a 32-bit compiler or download the precompiled version instead.


Updated 2008-03-18 – Niko Ritari